+ Reply to Thread
Results 1 to 3 of 3

Thread: 9 plate cell, not enough hydrogen

  1. Default 9 plate cell, not enough hydrogen

    Hi,

    I've been trying to build my own generator, but I'm having really low hydrogen production, in this video you can see the setting, I wonder if you can help me find out what seems to be the problem, this is a 9 plate titanium hydrogen cell, the plates are 14cm x 14cm grade 2 titanium, the current is 24v and 15amp the electrolyte is potassium hydroxide to 2,5l of distiled water, I can't seem to understand what is the problem, what do you say?:https://www.youtube.com/watch?v=eY4P...utu.be

    Maybe my connections have leaks? But no water is coming out, so it must be a minor leak, I don't think it is enough to justify such low hydrogen production...


    Thanks!!

  2. Default

    Quote Originally Posted by Ricardoleite View Post
    Hi,

    I've been trying to build my own generator, but I'm having really low hydrogen production, in this video you can see the setting, I wonder if you can help me find out what seems to be the problem, this is a 9 plate titanium hydrogen cell, the plates are 14cm x 14cm grade 2 titanium, the current is 24v and 15amp the electrolyte is potassium hydroxide to 2,5l of distiled water, I can't seem to understand what is the problem, what do you say?:https://www.youtube.com/watch?v=eY4P...utu.be

    Maybe my connections have leaks? But no water is coming out, so it must be a minor leak, I don't think it is enough to justify such low hydrogen production...


    Thanks!!
    Did you solve it? I think there must be some short circuit, did you check voltage difference between plates?

    The video doesn't show correctly where can be the issue, the plates and the electrical connections.

    Other thing is your plates configuration, I think I see 2 positives in one side (on the edges) and one negative in the other side (the center) that gives us 9 plates for 24v in + n n n - n n n +, so you are feeding 6 volts in every water compartment, totally wrong.

    Is the cell working while recording? because the gauge in the power supply shows 0 amps? The cell isn't getting any current.

    Regards
    Last edited by jesusangel; 12-16-2014 at 07:51 PM.

  3. Default

    Why not you search for circuit diagram on google. Hope you get a right diagram which help you to generate more power.
    Last edited by Allen23; 04-14-2015 at 04:35 AM.
    Nothing to discuss

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts